Company Contact Us 사이트맵 로그인


공지사항
자주하는질문(FAQ)
온라인 상담
Contact Us
신청서 다운로드
공지사항

No 61
제목 [10월14일]Adobe Flash Player 신규 취약점 보안 업데이트 권고
작성일 2015-10-15 10:01:07
내용

제목 : Adobe Flash Player 신규 취약점 보안 업데이트 권고

url : http://www.krcert.or.kr/kor/data/secNoticeView.jsp?p_bulletin_writing_sequence=23665

개요

o AdobeFlash Player에서 발생하는 취약점을 해결한 보안 업데이트를 발표[1]

o 낮은 버전 사용자는 악성코드 감염에 취약할 수 있으므로 해결방안에 따라 최신버전으로 업데이트 권고

 

설명

o Adobe Flash Player의 취약점에 대한 보안 업데이트를 발표[1]

· 정보노출과 same-origin 정책을 우회할 수 있는 취약점(CVE -2015-7628)

· Flash broker API에 심층 방어 기능 포함(CVE-2015-5569)

· 임의코드 실행으로 이어질 수 있는 use-after-free 취약점(CVE-2015-7629, CVE-2015-7631, CVE-2015-7643, CVE-2015-7644)

· 임의코드 실행으로 이어질 수 있는 버퍼 오버플로우 취약점 (CVE-2015-7632)

· 임의코드 실행으로 이어질 수 있는 메모리 손상 취약점 (CVE-2015-7625, CVE-2015-7626, CVE-2015-7627, CVE-2015-7630, CVE-2015-7633, CVE-2015-7634)

 

영향 받는 소프트웨어

o Adobe Flash Player

소프트웨어 명

동작환경

영향 받는 버전

Adobe Flash Player Desktop Runtime

윈도우즈,

19.0.0.185 및 이전버전

Adobe Flash Player Extended Support Release

윈도우즈,

18.0.0.241 및 이전버전

Adobe Flash Player for Google Chrome

윈도우즈, , 리눅스

19.0.0.185 및 이전버전

Adobe Flash Player for Microsoft Edge and Internet Explorer 11

윈도우즈 10

19.0.0.185 및 이전버전

Adobe Flash Player for Internet Explorer 10,11

윈도우즈 8.0, 8.1

19.0.0.185 및 이전버전

Adobe Flash Player for Linux

리눅스

11.2.202.521 및 이전버전

Air Desktop Runtime

윈도우즈,

19.0.0.190 및 이전버전

Air SDK

윈도우즈, , 안드로이드, iOS

19.0.0.190 및 이전버전

Air SDK & Compiler

윈도우즈, , 안드로이드, iOS

19.0.0.190 및 이전버전

 

해결 방안

o Adobe Flash Player 사용자

- 윈도우즈, 맥 환경의 Adobe Flash Player desktop runtime 사용자는 19.0.0.207버전으로 업데이트 적용

· Adobe Flash Player Download Center(http://www.adobe.com/go/getflash)방문하여 최신 버전을 설치하거나, 자동 업데이트를 이용하여 업그레이드

- Adobe Flash Player Extended Support Release 사용자는 18.0.0.252 버전으로 업데이트 적용

- 리눅스 환경의 Adobe Flash Player 사용자는 11.2.202.535 버전으로 업데이트 적용

- Adobe Flash Player가 설치된 Google Chrome은 자동으로 최신 업데이트 버전 적용

- 구글 크롬 및 윈도우 8.x, 10 버전의 인터넷 익스플로러 10, 11, EDGEAdobe Flash Player를 설치한 사용자는 자동으로 최신 업데이트가 적용

- AIR desktop runtime, AIR SDK Compiler, AIR for Android사용자는 19.0.0.213 버전으로 업데이트 적용

 

용어 정리

o Use-After-Free 취약점 : 소프트웨어 구현 시 동적 혹은 정적으로 할당된 메모리를 해제했음에도 불구하고 이를 계속 참조(사용)하여 발생하는 취약점

o Adobe AIR(Adobe Integrated Runtime): HTML, JavaScript, Adobe Flash ActionScript를 사용하여 브라우저의 제약 없이 독립 실행형 모바일 및 데스크탑 웹 애플리케이션을 구축하거나 사용할 수 있는 환경을 제공하는 도구

 

기타 문의사항

o 한국인터넷진흥원 인터넷침해대응센터: 국번없이 118

 

[참고사이트]

[1] https://helpx.adobe.com/security/products/flash-player/apsb15-25.html 

[10월19일]Adobe Flash Player 신규...
[10월14일]MS 10월 보안위협에...

목록보기